Routerboard SNTP Client

How to set the NTP client on a Mikrotik router using the Terminal

/system ntp client set enabled=yes primary-ntp=###.###.###.### secondary-ntp=###.###.###.###

Change the ### for IP address’s

Once done use the below to check if the settings has been applied

/system ntp client print

Below are two IP addresess for NTP servers that I use, they might not work for you though,

82.219.4.30 and 217.114.59.66

Once don’t forget to set your time zone information, under System > Clock

What version of Centos is my server running?

This post shows how to find out what version of Centos you are running from the command line.

tail /etc/redhat-release

This will output the version in a simple format: Centos release 5.10 (Final)

 

Subnet Calculator

Please use this link to calculate IP Subnet

NRPE config file on Centos

/usr/local/nagios/etc/nrpe.cfg

Remove a folder in Linux

This is the command to remove a folder/directory including its contents, use with caution as you wont get an “are you sure” prompt

rm -rf example

In the above example it would delete a folder/directory called example. Just change that to your folder/directory name.

The below code will do the same as above, but you will be prompted are you sure for each deletion.

rm -r example

 

Port Forwarding on a Mikrotik Routerboard

The below example shows a simple port forward that is forwarding TCP, Port 32400 (Plex) to the internal address 192.168.88.250 (Plex Media Server)

This string is entered into the console.

 

/ip firewall nat add action=dst-nat chain=dstnat disabled=no dst-port=32400 in-interface=ether1-gateway protocol=tcp to-addresses=192.168.88.250 to-ports=32400

Mount a Windows share in Centos 6

mkdir /mnt/win
yum install samba-client samba-common cifs-utils

Edit the /etc/fstab file and add a line like:

\\winbox\getme /mnt/win cifs user,uid=500,rw,suid,username=sushi,password=yummy 0 0

Zyxel P660 – Removing secured web IP

If you have locked down the web management port to 1 IP address and you need to access it from a different IP you can telnet to the router and using the below commands remove the secured Ip address allowing access from the web gui from any IP.

sys server load

sys server secureip web 0.0.0.0

sys server save

sys server disp

 

Draytek 2860 Port 443 / SSL not working port forward

draytekThere seems to be a bug in the Draytek 2860 router, even though I had changed the management ports from the default 80 and 443 to 8080 and 8080. I was still unable to port forward any 443 traffic and would end up getting an 404 error page from the Draytek 2860.

The next thing I tried was to disable the SSL vpn in the remote/vpn section, this made a change as I now no longer got the 404 error page from the router while trying to browse to https://mail.mydomain.com but still the port forwarding was not working.

After drilling down deeper into the Draytek 2860 SSL VPN settings, I changed the port the SSL VPN uses from 443 to 44444. I did not think that this change would make a difference as the SSL VPN was disabled, I was wrong!  The 443 port forward started working, so even though the SSL VPN was disabled, it seems that port 443 was still in use by it.

I hope this post helps others!

TCPDUMP to sniff headers

This tcpdump command will grab the first 1024 bytes (vs. smaller 68 or so) and line buffer the output for all packets using port 80 (http)

tcpdump -s 1024 -l -A port 80